AVRO030: Getting Started with IAR Embedded
Workbench for Atmel AVR

Features

How to open a new workspace and project in IAR Embedded Workbench
Description and option settings for compiling the c-code

Setting up the STK500

Using AVR Studio for debugging and programming

Introduction

The purpose of this application note is to guide new users through the initial
settings of IAR Embedded Workbench, and compile a simple C-program. The
application note shows setup of a new project to generate a debug target that can
be loaded into AVR Studio. AVR Studio is used for both debugging and to
download the code into the device installed on the STK500. A simple ledchaser is
used as an example, written for the ATmegal®6.

Figure 1. Tools overview.
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Preparations

Getting Started

Creating a new
workspace in IAR
Embedded Workbench
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This application note is written for the IAR Embedded Workbench 3.20. From this
point it's assumed that a working copy of this IDE is installed. Both IAR’s homepage
www.iar.com and AVRFreaks.net are suitable sources for download. You also need
to install AVR Studio. A copy could be downloaded free from www.atmel.com or
installed from the cd following the STK500 development board. The development
board should be working with it's default settings, so just unpack and follow the
instructions given later in this text.

You have now installed all tools needed for this getting started, as described in
preparations. When working with programming in general it's important to have some
structure in your coming projects and code. IAR Embedded Workbench is made to
support such demands. The upper abstraction of a task is called a workspace, within
each workspace you can add projects. The projects added in a workspace could be
supporting the same device or have something in common. Each project contains
code and settings for each target. So what we need to do is first make a workspace,
then add a new project to this workspace. When this is done you should be able to
include an application code to your project and make all the settings for the target
AVR on your STK500 board. A sample application code is found together with this
document, and should be unzipped and saved at a proper location, ex.
“C:\users\code”.

Open IAR Embedded Workbench. Follow the list below to make your first project, the
“ledchaser”:

1. Click new under the File menu.
2. Select “Workspace” and click OK.

3. Next dialog is for selecting name of the new workspace, type in “ledchase”. Set the
“Save in” path to: “C:\users\code” and hit OK.

Your IAR IDE window should now look like that of Figure 2.

Figure 2. The IAR Workspace.
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Creating a new project
in IAR Embedded
Workbench
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When the new workspace is created, you'll see a pane to the left in the IAR window
named “ledchase”. To make a new project, “ledchaser”, do the following:

1. Click “Create new Project” under the Project menu.

2. In the next dialog, select the “ledchase” directory as your working directory, in this
case: “C:\users\code”, and type “ledchase” in the project name field.

3. Click “Add Files” under the Project menu, and select the “ledchase.c” source file.
4. Click the open button and this file will be added to the project.

5. Double click the “ledchase.c” under the “ledchase” project, and feel free to resize,
move etc.

6. Click “Save all” in the File menu. Your project is now completed.

Figure 3 shows what this will look like in IAR Embedded Workbench.

Figure 3. Project with ledchase.c included.
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Setting up targets in IAR You should now have a workspace which contains the “ledchase” project, where your

Embedded Workbench
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source file is located. The next step is to tell what you need from the IAR compiler
and linker. In this context it's valuable to work with two targets and their configuration.
The IAR Embedded Workbench has two default targets; Debug and Release. The
Debug target will make an object file that AVR Studio can use for debugging. The
Release target will be a binary file for loading into the flash of your selected AVR. The
settings for both targets are done under the Project menu. The steps must be
repeated twice; once for the Debug target and once for the Release target.
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Figure 4. Selection of target.
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Be sure the Debug target is selected, see Figure 4, and go through the list below:

1.

Make sure the right target is selected in the drop-down menu of the project box in
your IDE.

. Click “Options” under the Project menu.
. In the “General” category, under the “Target” pane, select processor configuration

for ATmegalé.

. Chose memory model “small”.
. Under the “Library Configuration” pane, check to enable bit-definitions in 10-

included files.

. Select the “XLINK” category.
. Set the output format to “Other” —“ubrof8”. This produces an object file that AVR

Studio will recognize when the project is built.

. Close the target options dialog by clicking “OK”.

The same steps should be repeated for Release target, except:

In step 7, select “Other” — “Intel-standard” as output format. This setting tells the
compiler to make a hex file that can be loaded into the flash.

In the “ICCAVR” category, under the “Optimization” pane, select Medium
optimization. This way the compiler may be optimized for code size or execution
speed. Low degree of optimization gives best support for debugging.

When this is done, save all once more. Then select the Debug target and click “Make”
in the Project menu or press F7 to build the project.
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Before using the STK500 board be sure the power is turned off. The board should be
supplied with an ATmegal6 16PC microcontroller. If not already installed, carefully
insert into the socket marked SCKT3100A3. The microcontroller has a notch that
should be pointing the same way as the similar notch found on the socket. When all
set, you should inspect that the following jumpers are set:

e VTARGET: On-board VTARGET supply connected.

¢ AREF: On-board Analog Voltage Reference connected.

e RESET: On-board reset system connected.

e XTALL: On-board clock system connected.

e OSCEL: Between pin 2 and 3. Enables software clock signal.

e Remove any other jumpers.

IR

i NN

For further reading on this subject, please consult AVR Studio help under “STK500
User’s Guide” and “Jumper Settings and Special Cabling”.

Connect the 10-pin ribbon cable between PORTB and LEDs headers. This will allow
displaying the state of the ATmegal6’s PORTB output.

Connect the 6-pin ribbon between ISP6PIN and SPROG3 headers. This will allow
the AVR Studio programming the microcontroller.

Connect a RS232 cable from your computer to the connector market “RS232 CTRL”
on the STK500 board. Turn power on! Now your jumper section should look like that
in Figure 6.
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Figure 6. Cabling on STK500.

Using AVR Studio

IAR Embedded Workbench AVR Studio is project based, so debugging and
development is done within a project handling your files. Open AVR Studio, and the
project manager will be launched, and new projects can be made or old projects
loaded. To open the “ledchase” project:

e Select open and browse to the file \Debug\Exe\ledchase.dbg in your projects
directory.

e Select AVR Simulator as debug platform and ATmegal6 as device.
e Press Finish

e The project is now ready to be debugged in the simulator or programmed into an
AVR device.

Take a moment and read through the ledchaser code. Try understanding what it will
do, before simulating or programming. The ledchaser application is just a simple ‘0’
walking on PORTB. ‘0’ is used because the LEDs on the STK500 are in a sink
configuration, and will be lit when given a ‘0’ value.

6 AVRO030
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Figure 7. AVR Studio.
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AVR Studio is Windows based, and its editor GUI can be divided into four main
sections, as seen in Figure 7.

A.

B.

The Workspace contains information about the files in the project, 10 view, and
info about the selected AVR.

The editor contains the code being edited or debugged.

The output window displays status information while the System Tray displays
information about which mode AVR Studio is running in.

Menus included standard Windows menus like save and load file, cut & paste,
and other AVR Studio specific menus like Assembler options and debug
functions. The toolbars act as shortcuts to menu functions.

Before programming the microcontroller it is valuable using the debugger to verify that
the code works. Single step through the code and verify that:

1.P
2.S

ORTB and DDRB is set to OxFF.
ee that a PORTB has a running ‘0’. Use Step Into (F11) to see this. See Figure 8

for reference.
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Figure 8. Tools and I/O view.
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void wait({void): o
B BootLomn Tool used for single step
BN E Rel] ~# Include definition file
&3 EEPROM #include <ioml6 h>
C3 EXTERNAL_INTERRUPT #include <inavr h»
E
EEJTAG int main{ woid )
B-52 PORTA
52 PORTE unsigned char led:
i-28 PORTE
# DDRE FORTE = 0xFF: -~Give PORTE and "led" a initial startvalus
[ led -1
=2 PINB
PORTC DDRE = 0xFF: -~Set PORTE as output
PORTD
=1 while{l){ s Eternal loop
PORTE = ~led: < Invert the output =zince a zero means: LED on
TIMER_COLNTER_0 = led <c= /7 Move to next LED by perforning a rotate left
TIMER._COUMTER,_1
TIMER_COUMTER_Z if {lled) led = 1: .~ If overflow: start with ledl again
29 TWI . . . B
E‘;l USART wait(): ## Uncomment thiz line for the 'Release' build
Bl WATCHDOG +
PORTB IfO view
S/ #%% Prinitive wait() function *xx
void wait{void){
unsigned char i.3:
for(i=0:1i<255:i++)
for(j=0:3<255:3++):
Srroject 210 (@00 | [T ap

s
77 function prototype

The code is verified and working, and its time to power up the STK500 board and
load the program into the ATmegal6. When power is on, a small led in the upper right
corner should be lit red. To program the device select “STK500/AVRISP/JTAG ICE”
from the Tools menu. A program manager will pop up, looking like that of Figure 9.
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Figure 9. STK500 program window.
=loix|

Pragram | Fuses | LockBitsl Advancedl Board | Auta |

 Device

ATmegalf Eraze Device |

— Programrning rade
* |5P ¥ Eraze Device Before Programming
" Parallel/High Yoltage Serial ¥ Weiify Dievice After Programming

r~Flash
% Lse Cuent Simulatar/Emulator FLASH Memary

" Input HEX File IC:\users\code\.ﬂ.\-fH_training\Hands-on Giettin _l

Program | Yerify Read |

~EEFROM
" Lse Cument Simulator/Emulator EEPROM Memary

@ Input HEX File | [

Program | Yerify Read |

2]
Detecting on Auta’..
5TRB00 found on COM2:
Getting revisionz.. HW; 0202, SW Major: 0201, 54 Minor 0:12 .. OK J

Make sure that the ATmegal6 is selected as device, programming mode is set to
“ISP” and under Flash “Use Current Simulator/Emulator FLASH Memory”. This will
load the current code into device flash. Press the “Program” button, and wait while the
Atmegalb is being programmed. Soon you should see the led start walking.

This note is completed and you've made your very first AVR project, using the IAR
Embedded Workbench. For more information regarding IAR Embedded Workbench
visit IAR’s homepage www.iar.com or have a look at under the help menu. AVR
Studio also includes a great source for help. The online help found under AVR
Studio’s help menu, will solve many problems. Further reading and application notes
can be found at www.atmel.com and www.avrfreaks.net.
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